Only fresh browsers with Br.Asst.

A tool to check and update your web browser

Unfortunately it was not possible to detect your browser, because it looks like you're a robot

anyway, we hope that you can still find here something interesting

Why do you need Br.Asst.?


Despite the fact that browser nowadays learned to update themselves without bothering users, older version of such software are still in use by many people. As a result, for old browser versions owners websites and systems may perform and look differently then it was intended by its developers. Do not spoil your impression - simply always use the latest browser version!


We, the CHEERS! Unlimited web-agency, developed Br.Asst. - Browser Assistant to take care of our customers and users. Br.Asst. will help you to find out whether your browser is outdated and show you where to get the latest version of today's most popular ones.

Choose your browser

  • Google

    Chrome

    Current version: 51.0.2704.63

    We strongly recommend that you remove the old version before installing the new one while keeping your settings and browsing data (most of the modern browsers do offer such option), or just use your browser's built-in updater

    preferred by

    47.3%

    of Internet users

  • Apple Inc.

    Safari

    Current version: 9.1.1

    We strongly recommend that you remove the old version before installing the new one while keeping your settings and browsing data (most of the modern browsers do offer such option), or just use your browser's built-in updater

    preferred by

    20.7%

    of Internet users

  • Microsoft

    Internet Explorer

    Current version: 11.0.28

    We strongly recommend that you remove the old version before installing the new one while keeping your settings and browsing data (most of the modern browsers do offer such option), or just use your browser's built-in updater

    preferred by

    12.3%

    of Internet users

  • Mozilla Foundation

    Firefox

    Current version: 46.0.1

    We strongly recommend that you remove the old version before installing the new one while keeping your settings and browsing data (most of the modern browsers do offer such option), or just use your browser's built-in updater

    preferred by

    11.4%

    of Internet users

  • Opera Software

    Opera

    Current version: 37.0.2178.43

    We strongly recommend that you remove the old version before installing the new one while keeping your settings and browsing data (most of the modern browsers do offer such option), or just use your browser's built-in updater

    preferred by

    3.2%

    of Internet users

  • Click on desired browser or just drag it here

You can use Br.Asst. for your own websites!

We provide free and simple API for developers and webmasters. If you wish your users to be always aware of their browser version and could easily update it to see your projects the way they should be - join up!

HTML widget

Data in JSON

Choose desired API type by dragging the slider in its direction

If you're experiencing difficulties with HTML-widget embedding or cross-origin request for JSON, please, refer to the detailed parameters description and examples on our GitHub repository:

Out of the box HTML5 widget

With provided JavaScript and simplest integration you will get neutrally styled widget, ready to be embedded on any of your website page. If the user’s browser version is outdated, the widget will show itself to propose an update. Don't be afraid to seem intrusive: if user declines once, he will see the widget no longer

  • Plug in the script file before closing </body> tag on page that should display the widget:

    <script src="brasst_api.js"></script>

  • Initialize the script right after inclusion. Additionally you can specify the widget display language, which is supported by Br.Asst., by passing an object with 'locale' parameter into the constructor function:

    <script>

        var brasst = new Brasst({ locale: "en" });

    </script>

Done!

Required data in JSON format

You can get only the necessary data to use it as you see fit. Object will contain information gathered from client's User-Agent, as well as the client browser version and Boolean value that shows whether it's outdated or up to date. In case if browser is not detected or is not supported on user's operating system, we'll additionally send a warning string identifier

  • In order to get the response from Br.Asst. in JSON format you'll have to make a CORS GET request at https://brasst.net.ua/api with additional parameter 'type=json':

    https://brasst.net.ua/api?type=json

  • Received object will look similar to this:

    • {
    • "browser": "Some browser",
    • "vendor": "Some vendor",
    • "osFamily": "Some system",
    • "stableVersion": "42.0",
    • "clientVersion": "24.0",
    • "isOutdated": true,
    • "stableVersionLink": "https:\/\/www.somevendor.org\/somebrowser",
    • "userWarning": null
    • }

You can work with the data now!